Rainers Horen
Sonntag, den 18.05.2008 [19:12]
Ein so schöner Sonntag schreit nun wirklich nach der Beschäftigung mit einem äußerst mächtigen Web-Content-Managment-System. Mittlerweile ist klar, das in dem Typo3winstaller enthaltene DummyPaket tut überhaupt nichts, außer dass das Andrenalin steigt. es ist noch nicht einmal möglich, das AdminPasswort zu wechseln. Testen wir doch einmal das Quickstarterpaket. Jetzt geht zumindest Einiges. Komisch ist nur, dass die Sprache des Verwaltungswerkzeuges nicht umschaltbar ist. Irgendwas hakt eben immer. So, nach dieser versuchten Umschaltung der Sprache geht nun auch das Löschen von Seiten in dem Demo nicht mehr. davon träumt der Kaiser! Natürlicht lässt sich aus ebigem Grund die Sprachumschaltung stornieren. Jetzt kommt wieder der altbekannte leere Teilbereich. Was zeigt das Systemlog? Der Admin hat seinen realen Namen und seine Standardsprache gewechselt. Ist OK. Verschiedene Seiten sind gelöscht – nun aber kommen trotz Aktionen (beispielsweise Sprachwechsel) keine Meldungen mehr. Das hatten wir schon beim Dummypaket … Wenn das, laut Eigenwerbung ein sehr mächtiges CMS ist, dann macht das eun wenig Angst, wenn das System schon nach wenigen, banalen Aktione so viel fehlert.

Nun gibt es noch die Testsite-Umgebung. Mal sehen, was jetzt nicht geht. Lassen wir mal die Englische Sprache. Dem Endkunden wird es freuen. Ah, jetzt stürtzt es schon beim Nachladen der Erweiterungsliste ab. OK, viel Zeit gespart. Vielleicht gibt es so ein Herrschaftswissen, worauf man alles nicht klicken darf. Ach so. In dem Paket bin ich typo3 und nicht admin. Also nochmals als Chef eingeloggt. Jetzt kommt die Meldung über die nicht aktuellere Erweiterungsliste auf dem Server – somit kann ich nicht mehr online die Module nachladen. Ach, nun doch. Wo kommt nur die Liste her, ich ahbe sie nicht geholt. ist vielleicht bei dem Paket anders. Jetzt will ich die Sprache wechseln und das System meldet: &bdsquo;Nutzer typo3 hat vor x Minuten begonnen, an dieser Stelle etwas zu schrauben.“. Klar, das war ich selber und da es abgestürzt ist, haben wir jetzt den Schlamassel. Idee: die ganze Chose mal anhalten und neustarten. Der Fehler bleibt. Jetzt könnte man den Google-Gang einlegen. Könnte sein, dass sich das Locking von selbst über eine Zeitüberschreitung löst. Bis jetzt werden fast alle Aktionen mit leerer Screenbox quittiert. Das Schlimme ist, ich bin mir keiner Schuld bewusst. Es ist ein frisch installiertes System und ich stelle nur die Grundlagen ein. Von Systemvertrauen ist nun wirklich nicht zu sprechen. Wie man so hört, haben andere Fans absolut keine Probleme.
Beitrag kommentieren

Sonnabend, den 17.05.2008 [18:10]
Irgend so ein Spinner (wenn ich Dich kriege – wehe Dir!) hat bei seiner Spammailversendung („wir wissen, was Sie wollen/ wieder Spaß am Leben …“) unsere eMail-Adresse als replyto eingesetzt. Heute früh waren ca. 4000 Rückläufer im Briefkasten. Zumindest haben wir jetzt wegen der ganzen Abwesenheitsnotizen eine ganze Menge gültiger Adressen. Dankeschön für den Kurzweil! Kommt gleich in den Mülleimer. Nur gut, dass es noch eine Welt außerhalb des Internets gibt und deshalb geht es hinaus auf den Goldbekmarkt. Es ist ein Markttag wie jeder. Neben den althergebrachten Buden und Wägen, die hier offenbar schon zur Zeit der Weimarer Republik standen. gibt es immer wieder hoffnungsvolle Neuanfänge. Aktuell ist gerade gefärbtes und aromatisierter Puffmais (pop corn), Modeschmuck und selbstgemachte Senfe und Essige. Erfahrungsgemäß ist bei solchen Hobbygeschäften die Halbwertszeit sehr gering. Überraschenderweise war heute der Spargel halb so teuer wie letzte Woche. Straßenpreis war ca. 6 € für 4 Pfund.

Beitrag kommentieren

Donnerstag, den 15.05.2008 [18:17]
Fünf Tage ohne Blog? Da muss etwas Ernsthaftes passiert sein. Und so ist es auch. Nach fast einem Jahr Abstinenz beginnt heute ein neues TYPO3-Projekt. Was noch besser ist: die Entwicklungsumgebung soll auf XP laufen. Das scheint ja alles kein Problem zu sein. Ein kurze Suche im Netz fördert den¬Typo3winstaller zu Tage. Das geht ja nun bei Windows ganz einfach. Da wird das Ding runtergeladen und auch geschwind gestartet. Et voilà – schon läuft der Indianer, die Datenbank, PHP und auch das geliebte PHP. Das lässt durchaus (aber zaghaft) gute Gefühle hochkommen. Nun noch das Wunderwerkzeug Templavoilà installiert und gemäß Lehrbuch den entsprechenden Zauberer gestartet. Nun soll man eine neue Site anlegen. das geht nicht. Der alte (Demo-)Inhalt lässt sich auch nicht beseitigen. Na gut. Dann eben den ganzen Schlamassel wieder runter von der Platte und nochmal ran. Muss ja funktionieren. Eine Wiederholung bringt erwartungsgemäß auch nichts. Offenbar passt dieses Paket nicht zu Templavoilà.

Was gibt es sonst noch für Wege nach Rom? Vertrauen wir einmal nicht dem Fertigpaket, sondern versuchen wir, dem Kram einzeln einzuspielen. Stichwort WAMP. und siehe da es findet sich ¬Typo3Wamp – auch nicht schlecht. Das Paket beinhaltet zwar nur die zweitaktuellste TYPO3-Version, aber wenn es das kleine Problem löst?! Also wieder die Platte putzen und das Paket installiert. Fühlt sich erstmal gut an und nach einigen Augenblicken sind wir im TYPO3-Backend. Jetzt nun schon zum dritten Mal den ExtensionManager gestartet, um das TemplaVoila einzubauen. Dazu muss man die Liste der verfügbaren Erweiterungen laden. „Liste der Erweiterung ist aktuell, deswegen wird der Download nicht gestartet.“. Auch nicht schlecht: jetzt muss man die Erweiterungen händisch holen und via Upload einbinden. Fängt ja gut an!
Beitrag kommentieren